[jboss-user] [JBoss jBPM] - Re: JBPM 3.2.1 web app?does not display deployed process

jdickins do-not-reply at jboss.com
Fri Jul 27 19:31:50 EDT 2007


Thank you for the suggestion, I will try it. However, before when I've tried saving my process archive locally (pressing the button marked "save process archive locally") and when I deployed that from the web app I got the same error message as when I deployed just the process definition. Is that method what you meant?

anonymous wrote : I'm going to work through this documentation:
  | http://www.jboss.com/products/jbpm/docs/deployment
  | To see if the other deployment options work. 

The document I found yesterday, while being interesting, did not seem to help my problem as it is not deployment in different environments that I am having a problem with but deployment in any environment.

I think the first replier was on the right track: I may have a mismatch between my Runtime and my jbpm suite although I thought I'd fixed that problem.

Looking at the basic documentation again,


I have the feeling in my initial set up I may have inaccurately set up the relationships between Eclipse and the Runtime and the jbpm suite. I am going to un-install and re-install on Monday and see what comes of it.

On a side note, when I am deploying, I have set my "Server Deployer" to "/jbpm-console" rather than"/jbpm-console/upload" because 1) that way it matches the url I use to view the web app and 2) when I deployed to "/jbpm-console/upload" I received an error which I thought indicated that it could not find "http://localhost:8080/jbpm-console/upload". This lead me to try to get the information I inputed into the deployment fields the match the url I was going to (duh). When I tried deploying to "/jbpm-console" I recvied no error. And my process definition did not display. I can post the error message I received when I deployed to the /upload Server Deployer if it is relevant.

I am a little nervous about this change because it goes against what the jbpmGettingStarted guide says, but it does cause my process to say that it deployed successfully. 

Thank you to everyone who has commented on my question. Any thoughts on this or any other aspect of this problem would be appreciated.

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4068399#4068399

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4068399

More information about the jboss-user mailing list