[jboss-user] [JBoss Seam] - Re: Rendering buttons in a datatable fails

hubaer do-not-reply at jboss.com
Tue Mar 13 11:13:12 EDT 2007

Thank you app4you,

So I played another time with my application and I think I resolved the problems with your help.

I couldn't put the DataModel in the session scope, because it is only allowed to put it in the page or undefined scope.

But I put an @Begin at my factory method. So the action bean stays in the conversions. That's ok for me.

Now I can pass parameter via the s:button (The commandButton works too !?!, but I change to the s:button).

I tried out creating a 2nd bean for the edit action. But it also works now if all is in the same bean.
I think, it must be the conversation.

So now the buttons are only shown on those entries, which are editable and the correct entry is passed if I click on "Edit"!

Thanks again

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4027575#4027575

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4027575

More information about the jboss-user mailing list