[jboss-user] [JBoss Seam] - Oddness - javax.persistence.EntityNotFoundException

damianharvey do-not-reply at jboss.com
Tue Mar 20 13:48:44 EDT 2007

I'm having one of those days where everything was working and now, inexplicably, it ain't.

I have a dataTable that is calling a basic Entity remove, but it is generating the error below:

 javax.persistence.EntityNotFoundException: deleted entity passed to persist: [com.blah.entity.PortTradeList#<null>]

I have then tried using code generated by SeamGen and the same error results (so it's not my dodgy page code at fault). I've then replaced the entities with a version that I knew was working. Same problem.

I put a debug line directly above the super.remove() and it confirmed that the entity was populated and had an ID.

Can anyone think what may be causing this? Help much appreciated before I pull out my remaining single hair.



View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4029914#4029914

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4029914

More information about the jboss-user mailing list