[jboss-user] [Installation, Configuration & Deployment] - Jboss (sometimes) hangs on startup. Please help.

giants_fan do-not-reply at jboss.com
Wed May 2 14:09:21 EDT 2007


Usually, when I first boot up my machine, Jboss (4.03SP1) starts just fine, but after a few restarts, it just hangs.  Here's the stdout:

10:55:29,887 INFO  [Server] Root Deployment Filename: jboss-service.xml
10:55:30,418 INFO  [ServerInfo] Java version: 1.5.0_11,Sun Microsystems Inc.
10:55:30,422 INFO  [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.5.0_11-b03,Sun Microsystems Inc.
10:55:30,422 INFO  [ServerInfo] OS-System: Linux 2.6.20-15-386,i386
10:55:31,508 INFO  [Server] Core system initialized

and then it just sits there.  The console is responsive because I can Control-C out of it, but seems like it's waiting for something.  Here's where it stops in my boot.log file:

10:55:37,207 DEBUG [ServiceController] Creating dependent components for: jboss.system:service=ThreadPool dependents are: [ObjectName: jboss:service=WebService
  I Depend On:
, ObjectName: jboss:service=Naming
  I Depend On:
10:55:37,207 DEBUG [ServiceController] Creating service jboss:service=WebService
10:55:37,207 DEBUG [WebService] Creating jboss:service=WebService

Any ideas?  

When I run the minimal server (-c minimal) everything works.  This happens with a clean install of just the default (-c default) server.  I've tried several different JVMs (1.42, 1.6) and also combinations with other Jbosses (4.04, 4.05) and have the same problem.  I suspect it's something machine specific, but I don't quite know where to look.  

Any help would be very appreciated.


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4042553#4042553

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4042553

More information about the jboss-user mailing list