[jboss-user] [JBossWS] - jbossws-native-2.0.2.GA doesn't deploy out of the box on jbo

klease do-not-reply at jboss.com
Thu Nov 29 16:42:36 EST 2007

I have a 4.2.1.GA with jbossws-2.0.1.GA installed.
I ran undeploy-jboss42 in the 2.0.1.GA installation directory.
Then I ran deploy-jboss421 in the jbossws-2.0.2.GA installation directory.
Tried to start jboss and got lots of ClassNotFound errors.

After hunting around a bit, I see that in macros-deploy-native.xml the macro-deploy-native421 definition contains this.
<copy todir="${jboss421.home}/server/${jboss.server.instance}/lib" overwrite="true">
  |         <fileset dir="@{thirdpartylibs}">
  |           <include name="jbossws-jboss421.jar"/>
  |         </fileset>
  |       </copy>

But there is no jbossws-jboss421.jar jar in the 2.0.2.GA installation zip.

I dropped in the jbossws-jboss42.jar from the 2.0.2.GA installation into server/default/lib and also client/lib. This deploys without errors and runs all the 2.0.2 test cases.
Are there any known incompatibilities with this jar and the new jbossws version?

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4109077#4109077

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4109077

More information about the jboss-user mailing list