[jboss-user] [Installation, Configuration & DEPLOYMENT] - Re: 4.2.2 wont deploy my persistency unit

alllle do-not-reply at jboss.com
Fri Nov 30 15:18:05 EST 2007

I wonder if anyone has encountered the same problem described here? 

I am having the same problem. My EAR contains a module app.jar, which contains the persistence.xml file:

  | <persistence>
  |     <persistence-unit name="myDB">
  |         <provider>org.hibernate.ejb.HibernatePersistence</provider>
  |         <jta-data-source>java:appDS</jta-data-source>
  |     </persistence-unit>
  | </persistence>
Where the appDS is deployed with a xxx-ds.xml file with no problem. However, I am getting the same NoInitialContextException. 

I tried to deploy the app.jar under module/java as well as module/ejb but same problem. I also tried to add:
  |             <property name="java.naming.factory.initial" value="org.jnp.interfaces.NamingContextFactory" />
  |             <property name="java.naming.factory.url.pkgs" value="org.jboss.naming:org.jnp.interfaces" />
  |         </properties>
to the persistence.xml file and same error.

I have no clue what is wrong. It's deployed to the server so no jndi.properties file should be needed. If so, why this error occurs?

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4109449#4109449

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4109449

More information about the jboss-user mailing list