[jboss-user] [JBossWS] - JBossWS 2.0.1 Inheritance problem

mrokka123 do-not-reply at jboss.com
Fri Sep 21 00:29:10 EDT 2007

I have tried @XmlSeeAlso on jbossWS2.0.1 to solved the type substitution problem[inheritance problem]. But it does not solved my problem. I have the following situation:

My Pojo classes

public class A extends java.io.Serializable{

public class B extends A{

public class C extends A{

Now webservice
@WebService(name = "MyWebServicePortType", serviceName = "MyWebService",
        portName = "MyWebServicePort",targetNamespace = "http://mywebservice.com")

@SOAPBinding(style = SOAPBinding.Style.DOCUMENT,
        use = SOAPBinding.Use.LITERAL,
        parameterStyle = SOAPBinding.ParameterStyle.WRAPPED)
public class MyWebService{
public String getClassName(A obj){
	String className=obj.getClass().getName();
return className; //it always returns ?A? on  jbossWS2.0.1 even if I pass the reference of B while calling this function from client

Does anybody knows the solution?

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4087014#4087014

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4087014

More information about the jboss-user mailing list