[jboss-user] [JBoss Seam] - Re: 1.2.1->2.0.0 migration: No active application scope

tynor do-not-reply at jboss.com
Fri Sep 21 13:49:13 EDT 2007

I've fixed this by changing my pages.xml configuration.  A wildcard that worked in 1.2.1 no longer works in 2.0.0.  On reflection, perhaps it never should have worked, but for the sake of the archives, here's what caused the problem: 

In my app, I need _all_ application pages to be password protected -- so I had this in my pages.xml: 

    <page view-id="*" login-required="true">
  |         <navigation>
  |             <rule if-outcome="home">
  |                 <redirect view-id="/home.xhtml"/>
  |             </rule>
  |         </navigation>
  |     </page>

I'm guessing that the problem is a chicken-egg thing with /login.xhtml (which is conceptually covered by the above wildcard).  In 1.2.1, this worked.  In 2.0.0, I get the "no active application scope" exception detailed earlier in this thread.

So my fix is to move all my password-protected pages into subdirectories and leave only the non-protected stuff in the root view.  pages.xml no longer has a "*" wildcard, only "/foo/*", "/bar/*", etc.

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4087365#4087365

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4087365

More information about the jboss-user mailing list