[jboss-user] [JBoss jBPM] - Re: jBPM in Websphere 6.0

sparklehorse do-not-reply at jboss.com
Fri Sep 28 03:37:10 EDT 2007

I've tried the approach of deploying jbpm-console.war under websphere
(previously i've modify WEB-INF/classes/hibernate.cfg.xml changing the db driver for my needs)

i've added hibernate jars which was a documented suggestion

Then i get

[9/28/07 8:52:39:493 CEST] 0000001e WebApp        E   Extension processor failed to initialize in factory: com.ibm.ws.jsf.extprocessor.JSFExtensionFactory at 41744174
java.lang.NoClassDefFoundError: edu.emory.mathcs.backport.java.util.concurrent.ConcurrentMap

i add
and put them inside WEB-INF\lib

then i get this

[9/28/07 8:55:44:569 CEST] 00000020 WebApp        E   Extension processor failed to initialize in factory: com.ibm.ws.jsp.webcontainerext.ws.WASJSPExtensionFactory at 53d853d8
java.lang.NoSuchMethodError: com/sun/faces/util/Util.getLogger(Ljava/lang/String;)Ljava/util/logging/Logger;

(i have tried to add also log4j and commons-logging but nothing changes)

...and the application is not work since if try to access the webapp i get

Error 403: SRVE0190E: File not found: /index.jsp

Furthermore there's some other problem because 
in the log i see 

[9/28/07 9:11:31:024 CEST] 000001e1 javaURLContex E   NMSV0310E: A JNDI operation on a "java:" name cannot be completed because the server runtime is not able to associate the operation's thread with any J2EE application component. This condition can occur when the JNDI client using the "java:" name is not executed on the thread of a server application request. Make sure that a J2EE application does not execute JNDI operations on "java:" names within static code blocks or in threads created by that J2EE application. Such code does not necessarily run on the thread of a server application request and therefore is not supported by JNDI operations on "java:" names. Exception stack trace: 
javax.naming.ConfigurationException [Root exception is javax.naming.NameNotFoundException: Name  not found in context "java:".]
        at com.ibm.ws.naming.java.javaURLContextImpl.throwConfigurationExceptionWithDefaultJavaNS(javaURLContextImpl.java:411)
        at com.ibm.ws.naming.java.javaURLContextImpl.lookup(javaURLContextImpl.java:388)
        at com.ibm.ws.naming.java.javaURLContextRoot.lookup(javaURLContextRoot.java:204)

which seems to be related to a bug fixed in bpm 3.2.3 i've seen
on jira 

I would like to use the console to deploy my processes and monitor
them.... i think i wil lgo for custom deploy
[examples here http://www.jboss.com/index.html?module=bb&op=viewtopic&t=85420]

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4089572#4089572

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4089572

More information about the jboss-user mailing list