[jboss-user] [JBoss jBPM] - Re: Problem in deploying processdefinition in a war file - S

syedtaj do-not-reply at jboss.com
Tue Apr 22 09:34:22 EDT 2008

Solved the problem

When we use the following code 

to parse the xml so that we can deploy it, It uses a ClassLoader internally instantiated by its own custom class – ClassLoaderUtil.java to load the resource, and for some reason it searches for the resources with respect to where the lib file – jbpm-jpdl.jar is present.

Till now I had placed the jar files in the <Jboss_home>\server\default\lib. I removed them and placed them in the automation.war/WEB-INF/lib and now it works. Am I missing something. How can the resource loader search with respect to where the lib is placed, shouldn’t it searching the entire classpath?

If I create my own class loader I am able to place it in the classpath and it picks it up, but since that would instantiate a separate class loader, it cannot find the action classes that would have been loaded by JBOSS class loader.

I know I am missing something, though it works now, I really would like to know why is the above phenomenon occurring.


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4145830#4145830

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4145830

More information about the jboss-user mailing list