[jboss-user] [JBoss jBPM] - Re: Unable to locate current JTA transaction

crued do-not-reply at jboss.com
Mon Aug 4 14:39:44 EDT 2008

"shilpa.kumar at indussoft.com" wrote : I am also getting the same error. I am working on jbpm3.2.2\jbpm-jpdl-3.2.2 & websphere 6. I am able to connect and give token.signal but at state-end i am getting this error. 
  |   | org.jbpm.db.JobSession deleteJobsForProcessInstance org.hibernate.TransactionException: Could not register synchronization
  |   | 
  | Can you please help me. I already running behind time. and saw all sites from almost 2 weeks. but still not getting any solution.....

I don't have a solution, but I'm experiencing the same problem, I think.  In my case, I'm manually clicking "End" while viewing a process instance in the jbpm-console web app.

I've followed the stack traces and found that the reason that the synchronization couldn't be registered is because of a NullPointerException that occurs inside CMTTransaction on line 156:

  | 154:	public void registerSynchronization(Synchronization sync) throws HibernateException {
  | 155:		try {
  | 156:			getTransaction().registerSynchronization(sync);
  | 157:		}
  | 158:		catch (Exception e) {
  | 159:			throw new TransactionException("Could not register synchronization", e);
  | 160:		}
  | 161:	}

So for some reason, getTransaction() is returning null...   

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4168559#4168559

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4168559

More information about the jboss-user mailing list