[jboss-user] [Clustering/JBoss] - Problems with JBoss clustering

agohar do-not-reply at jboss.com
Thu Aug 21 05:30:34 EDT 2008

I am having problems in jboss clustering, here is what i am trying to do:

We have 8 servers at 2 physical locations and these are all clustered well and were working fine with jdk1.4.2  and jboss-4.0.2. We wanted to upgrade our servers with new java 5 and jboss-4.2.2 versions and applications to use JbossWS and EJB3.0 versions. For that we put down the 4 servers (2 from each location) and upgraded them with new java and jboss versions and new upgraded applications. We are using udp multicast for the clustering so i changed the ports and IPs in following files to split the cluster:

- cluster-service.xml
- tree cache files
- jboss-web-cluster/META-INF/jboss-service.xml

I didn't change the partition name though and tried to run these both clusters in parallel. But got into problems, when i start any two of them they startup fine and create a new separate cluster fine but when i try to add third one, it is very very slow during start up and take ages to start, but doesn't throw any exceptions during startup and when it is up it throw:

  | 2008-08-20 01:07:45,008 ERROR [org.jgroups.protocols.UDP] [] failed receiving unicast packet
  | java.lang.ArrayIndexOutOfBoundsException
  | at java.net.PlainDatagramSocketImpl.receive0(Native Method)
  | at java.net.PlainDatagramSocketImpl.receive(PlainDatagramSocketImpl.java:136)
  | at java.net.DatagramSocket.receive(DatagramSocket.java:712)
  | at org.jgroups.protocols.UDP$UcastReceiver.run(UDP.java:885)
  | at java.lang.Thread.run(Thread.java:595)
  | 2008-08-20 01:07:45,008 ERROR [org.jgroups.protocols.UDP] failure in multicast receive()
  | java.lang.ArrayIndexOutOfBoundsException 

I tried every combination of servers any two servers run perfectly fine and third and fourth ones cause problems. The other cluster works perfectly fine its jsut the problem with the new one. I had upgraded jgroups version to jgroups-2.6.0-GA because of a bug and now using this (2.6.0-GA) version.

Please let me know if there is anything i can look at? Your help will be highly appreciated

Thank you

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4171712#4171712

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4171712

More information about the jboss-user mailing list