[jboss-user] [Tomcat, HTTPD, Servlets & JSP] - Re: PHP on TOMCAT

bmurphy77@mindspring.com do-not-reply at jboss.com
Wed Dec 3 13:53:10 EST 2008

Thanks JFrederic, 
Previously, I had been trying to get the libphp5 files from PHP binaries with axps2 configured and thought buildphp.sh was doing something similiar.

Consequently, I was running buildphp on its own. You made it too easy by including the php5servlet directory in the project directory. It was pretty clear all along, in truth, the more I go through the process and
learn, the more straightforward it becomes.

So, I compiled succesfully. untarred in $JBOSS_HOME and added the descriptions to web.xml.

On start up, I have trouble with libxml2.so, i think....undefined symbol: xmlTextReaderSchemaValidate .

I tried setting the LD_LIBRARY_PATH different ways, i tried it in run.sh just in case run.conf wasnt picked up and I also copied the files from the tarball into the /usr/lib/jdk1.5../.../server

I have spent some time trying to cajole it into seeing the libxm2.so group but im hitting a dead end

Here's the path setting from my run.sh and the error from the server startup ?

I greatly appreciate the help, You can forget how painful it was to learn to walk when you do it every day. Then you try something new on the computer and oh boy, the bruises may be mental but you are glad of the time spent when you are walking around on two legs.

run.sh :

anonymous wrote : LD_LIBRARY_PATH=/jboss/jboss-4.0.2/PHP/lib:jboss/jboss-4.0.2/bin/native;
  | export LD_LIBRARY_PATH;

server.log :
anonymous wrote : 2008-11-24 13:38:34,846 DEBUG [org.jboss.web.tomcat.filters.ReplyHeaderFilter] Adding header name: X-Powered-By='Servlet 2.4; JBoss-4.0.2 (build: CVSTag=JBoss_4_0_2 date=200505022023)/Tomcat-5.5'
  | 2008-11-24 13:38:34,915 DEBUG [org.jboss.invocation.http.servlet.InvokerServlet] localInvokerName=jboss:service=invoker,type=http
  | 2008-11-24 13:38:35,044 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/invoker]] StandardWrapper.Throwable
  | java.lang.UnsatisfiedLinkError: /usr/lib/jdk1.5.0_15/jre/lib/i386/server/libphp5servlet.so: /usr/lib/jdk1.5.0_15/jre/lib/i386/server/libphp5.so: undefined symbol: xmlTextReaderSchemaValidate, no libphp5servlet in java.library.path(/usr/lib/jdk1.5.0_15/jre/lib/i386/server:/usr/lib/jdk1.5.0_15/jre/lib/i386:/usr/lib/jdk1.5.0_15/jre/../lib/i386:/jboss/jboss-4.0.2/PHP/lib:/jboss/jboss-4.0.2/bin/native)
  | 	at org.jboss.web.php.Library.(Library.java:65)
  | 	at org.jboss.web.php.Library.initialize(Library.java:104)

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4194129#4194129

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4194129

More information about the jboss-user mailing list