[jboss-user] [JBoss Seam] - Re: JBoss Seam, a great product that doesn't work :(

lazar.mihai do-not-reply at jboss.com
Fri Jan 25 18:40:52 EST 2008

Wow, thanks a lot for the prompt reply :).

I had RHDS RC1 and eclipse jee with jboss tools.. What I'm doing is this. I'm making a Seam Web Project with JBoss Seam 2.0.0.GA on JBoss AS 4.2.0.GA

The template works fine. When I access Generate Entities from the tool i get a n error saying something about ejb3deployer not beeing initialized.

Because of the errors I tried going back to the command line. The template worked fine. 

Anyway.. I'm now doing JBoss AS 4.2.0.GA with JBoss Seam 1.2.1.GA looks like it works now. :-??

Also, what is that about Seam 2.0 being a technology preview ? Could that be the cause of the errors I get with deployment?

I'm pretty sure that when I was writting by hand I left out some configurations.

In conclusion it seems to be working for now. With Jboss Seam 1.2.1

Compared with Stripes, Seam still takes to much out of me, although if the facts on paper are right it will be worth it, at least that I'm hoping for.

Also found http://in.relation.to/Bloggers/Everyone/Tag/Seam, and it provided with some help.

If you know why I get that ejb3deployer error, or the most recent one
ERROR [SeamLoginModule] Error invoking login method
javax.el.PropertyNotFoundException: Target Unreachable, identifier 'authenticator' resolved to null

In the meanwhile I'll be playing with what works, don't think there is much more I can do right now :).

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4123693#4123693

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4123693

More information about the jboss-user mailing list