[jboss-user] [JNDI/Naming/Network] - Re: Data Source JNDI lookup fails in a WAR

avyo do-not-reply at jboss.com
Fri Jul 11 16:21:12 EDT 2008

anonymous wrote : Properties props= new Properties();
  | props.put(InitialContext.INITIAL_CONTEXT_FACTORY,"org.jnp.interfaces.NamingContextFactory");
  | props.put(InitialContext.PROVIDER_URL, "jnp://");
  | Context ctx = new InitialContext(props);
  | ctx.lookup("java:/TestDB");
I did all the possible combination with those properties but again no luck. 

I read the post that you mention and tried his solution but it didn't worked (I'm running on jboss 4.2).

In the meanwhile I found some workaround solution, I register my data source in the global JNDI rather then in the 'java:' one, it works fine but I need to check what are the implication (i.e. security ...).- any ideas??

Thanks you very much for your help.

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4163957#4163957

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4163957

More information about the jboss-user mailing list