[jboss-user] [Installation, Configuration & DEPLOYMENT] - Problems deploying app in a 64-bit environment

jimmycallaghan do-not-reply at jboss.com
Tue Jul 15 07:14:57 EDT 2008

I've been running Jboss5.0.0.Beta4 on my local (Ubuntu) machine and have an application running nicely. Unfortunately I can't move to JBoss5.0.0.CR1 because of a problem with persistence.xml in the META-INF directory of the EAR (http://jira.jboss.org/jira/browse/JBAS-5713).

My application is deploying correctly on my local machine but I couldn't get it working on the server. Basically, JBoss seems to ignore my EJB annotations when it deploys my application and it deploys each EJB into it's default location. Thus, when another part of the application tries to do a local lookup to a bean it cannot.

Since it was OK locally I put my application, its datasources and queue definitions into the relevant directories and tested. Everything worked. I then tarred up the whole lot (JBoss, datasources, EAR etc) and put it onto the server. I untarred and started the server and the EJBs were bound into their default locations and not where my @LocalBinding and @RemoteBinding binding annotations had specified. I am using the following import statements:

import org.jboss.ejb3.annotation.LocalBinding;
  | import org.jboss.ejb3.annotation.RemoteBinding;

The only thing that is different between the server and my machine is that the server is using a 64bit jdk and my PC is 32 bit. I've tried 3 different versions of Java on the server (jrockit-R27.1.0-jdk1.5.0_08, jrockit-R27.5.0-jdk1.6.0_03 and jdk1.6.0_07). I'm getting the same result each time.

Has anybody experienced anything similar?

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4164464#4164464

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4164464

More information about the jboss-user mailing list