[jboss-user] [JBoss jBPM] - Re: How to deploy a BPEL process using the APIs?

dhanushgopinath do-not-reply at jboss.com
Fri Jul 18 09:23:37 EDT 2008


I moved this entire deployment to a Webservice Impl that is deployed on a JBOSS AS. So no I presume I can use the default DataSource and not the Hibernate Server Mode over TCP.(Am I right??)

I am using the default Data Source, but still the same issue is coming.

The issue is18:40:58,385 INFO  [TomcatDeployer] deploy, ctxPath=/Workflow3, warUrl=.../tmp/deploy/tmp55362Workflow3-exp.war/
  | 18:40:59,103 ERROR [[/Workflow3]] Exception sending context initialized event to listener instance of class org.jbpm.bpel.integration.server.IntegrationConfigurator
  | org.jbpm.bpel.BpelException: process not found: name=Workflow3, targetNamespace=http://www.altair.com/Workflow3, version=null
  | 	at org.jbpm.bpel.deploy.DeploymentDescriptor.findProcessDefinition(DeploymentDescriptor.java:89)
  | 	at org.jbpm.bpel.integration.server.IntegrationConfigurator.contextInitialized(IntegrationConfigurator.java:56)

if you look at it you can see that when I am trying to deploy the web module it is not able to find the process that was deployed.

In this case graphSession.findLatestProcessDefinition is returning null

Why is it not able to find?

After deploying the process definition i tried to use the same API to find the process definition using the following code: In this case I was able to get it 

  | if (processDefinition instanceof BpelProcessDefinition)
  | 	    {
  | 	            BpelGraphSession graphSession = BpelGraphSession.getContextInstance(jbpmContext);
  | 	 	        graphSession.deployProcessDefinition((BpelProcessDefinition) processDefinition);
  | 	 	       ProcessDefinition  processDefinition2 = graphSession.findLatestProcessDefinition(processDefinition.getName(),"http://www.altair.com/Workflow3"); 
  | }

in this case processDefinition2  was identical as processDefinition.

But when I go ahead and deploy web module, it tries to find the deployed process definition it is returned null. Why is this happening.

Is there anything else I need to do ?

Please let me know. I am following the same code base as given earlier.


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4165325#4165325

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4165325

More information about the jboss-user mailing list