[jboss-user] [Messaging, JMS & JBossMQ] - JBossMQ failover issues

agohar do-not-reply at jboss.com
Tue Jul 22 10:07:18 EDT 2008


I am running two jboss instances in a cluster and deployed different queues/topics in all/deploy directory, but when i kill or shutdown first node, the other node is not able to take over and deploy the queues on it. I get following errors:
2008-07-22 10:54:32,989 INFO  [org.jboss.resource.adapter.jms.inflow.JmsActivation] Attempting to re
  | connect org.jboss.resource.adapter.jms.inflow.JmsActivationSpec at 15a0316(ra=org.jboss.resource.adapte
  | r.jms.JmsResourceAdapter at 1fb580 destination=topic/refreshRulesTopic isTopic=true tx=true durable=fal
  | se reconnect=10 provider=java:/DefaultJMSProvider user=null maxMessages=1 minSession=1 maxSession=15
  |  keepAlive=60000 useDLQ=true DLQHandler=org.jboss.resource.adapter.jms.inflow.dlq.GenericDLQHandler 
  | DLQJndiName=queue/DLQ DLQUser=null DLQMaxResent=5)
  | 2008-07-22 10:54:32,990 ERROR [org.jboss.resource.adapter.jms.inflow.JmsActivation] Unable to reconn
  | ect org.jboss.resource.adapter.jms.inflow.JmsActivationSpec at 15a0316(ra=org.jboss.resource.adapter.jm
  | s.JmsResourceAdapter at 1fb580 destination=topic/refreshRulesTopic isTopic=true tx=true durable=false r
  | econnect=10 provider=java:/DefaultJMSProvider user=null maxMessages=1 minSession=1 maxSession=15 kee
  | pAlive=60000 useDLQ=true DLQHandler=org.jboss.resource.adapter.jms.inflow.dlq.GenericDLQHandler DLQJ
  | ndiName=queue/DLQ DLQUser=null DLQMaxResent=5)
  | javax.naming.NameNotFoundException: queue/DLQ
  |         at org.jboss.ha.jndi.TreeHead.lookup(TreeHead.java:242)
  |         at org.jboss.ha.jndi.HAJNDI.lookup(HAJNDI.java:155)
  |         at sun.reflect.GeneratedMethodAccessor138.invoke(Unknown Source)
  |         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  |         at java.lang.reflect.Method.invoke(Method.java:585)
  |         at org.jboss.ha.framework.interfaces.HARMIClient.invoke(HARMIClient.java:312)
  |         at $Proxy314.lookup(Unknown Source)
  |         at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:667)
  |         at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:627)

Looks like the problem is only for DLQ queues, get the same above error for my own application defined DLQ queues.

I am running JBoss-4.2.2.

I've tried to deploy the queues to deploy-hasingleton directory but the problem is same. These queues are backed up by db.

Does anyone has any clue?


PS: i've also tried to put them under deploy-hasingleton/jms directory but of no use 

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4165896#4165896

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4165896

More information about the jboss-user mailing list