[jboss-user] [Beginners Corner] - Re: shutdown.bat and cntrl-c not working but web-console and

amast do-not-reply at jboss.com
Thu Jun 26 08:36:20 EDT 2008

Thanks again for your persistence!

"PeterJ" wrote : Based on your netstat output, I think that you changed the JNDI port to 9099 (the default is 1099). So you should be able to shut down from the same machine using: 
  | shutdown -S -s localhost:9099
That didn't shutdown, same "pause"

"PeterJ" wrote : 
  | Could you try with a Sun JDK?
Yea, I tried that, but the same result (thread break below). 

Listening for transport dt_socket at address: 8787
2008-06-26 08:30:27
Full thread dump Java HotSpot(TM) Client VM (10.0-b19 mixed mode):

"JDWP Event Helper Thread" daemon prio=6 tid=0x0aac5800 nid=0xf1c runnable [0x00000000..0x00000000]
   java.lang.Thread.State: RUNNABLE

"JDWP Transport Listener: dt_socket" daemon prio=6 tid=0x0aac2800 nid=0x650 runnable [0x00000000..0x00000000]
   java.lang.Thread.State: RUNNABLE

"Attach Listener" daemon prio=10 tid=0x0aab7800 nid=0x2ac runnable [0x00000000..0x00000000]
   java.lang.Thread.State: RUNNABLE

"Signal Dispatcher" daemon prio=10 tid=0x0aab6c00 nid=0xfc4 waiting on condition [0x00000000..0x00000000]
   java.lang.Thread.State: RUNNABLE

"Finalizer" daemon prio=8 tid=0x0aaa9000 nid=0xed8 in Object.wait() [0x0ac1f000..0x0ac1fa98]
   java.lang.Thread.State: WAITING (on object monitor)
        at java.lang.Object.wait(Native Method)
        - waiting on <0x02990b38> (a java.lang.ref.ReferenceQueue$Lock)
        at java.lang.ref.ReferenceQueue.remove(Unknown Source)
        - locked <0x02990b38> (a java.lang.ref.ReferenceQueue$Lock)
        at java.lang.ref.ReferenceQueue.remove(Unknown Source)
        at java.lang.ref.Finalizer$FinalizerThread.run(Unknown Source)

"Reference Handler" daemon prio=10 tid=0x0aaa4800 nid=0xf40 in Object.wait() [0x0abcf000..0x0abcfb18]
   java.lang.Thread.State: WAITING (on object monitor)
        at java.lang.Object.wait(Native Method)
        - waiting on <0x02990a40> (a java.lang.ref.Reference$Lock)
        at java.lang.Object.wait(Object.java:485)
        at java.lang.ref.Reference$ReferenceHandler.run(Unknown Source)
        - locked <0x02990a40> (a java.lang.ref.Reference$Lock)

"main" prio=6 tid=0x00295c00 nid=0x204 runnable [0x00000000..0x0090fdec]
   java.lang.Thread.State: RUNNABLE

"VM Thread" prio=10 tid=0x0aaa0000 nid=0x450 runnable

JNI global references: 324

 def new generation   total 960K, used 157K [0x02990000, 0x02a90000, 0x02e70000)
  eden space 896K,  17% used [0x02990000, 0x029b7790, 0x02a70000)
  from space 64K,   0% used [0x02a70000, 0x02a70000, 0x02a80000)
  to   space 64K,   0% used [0x02a80000, 0x02a80000, 0x02a90000)
 tenured generation   total 4096K, used 0K [0x02e70000, 0x03270000, 0x06990000)
   the space 4096K,   0% used [0x02e70000, 0x02e70000, 0x02e70200, 0x03270000)
 compacting perm gen  total 12288K, used 1450K [0x06990000, 0x07590000, 0x0a990000)
   the space 12288K,  11% used [0x06990000, 0x06afabb0, 0x06afac00, 0x07590000)
No shared spaces configured.

"PeterJ" wrote : 
  | Please don't bold your text, makes it too difficult to read.

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4160844#4160844

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4160844

More information about the jboss-user mailing list