[jboss-user] [JBoss Tools (users)] - Re: upgrade to WTP 2.0.2 breaks EAR deployment in JBoss Tool

matteg do-not-reply at jboss.com
Thu Mar 20 19:12:53 EDT 2008

I tried generating a new project using the new seam wizard and discovered the numerous errors described in these postings.
I was able to make the deployed application work by copying from another previously deployed seam-gen application.
That is, I copied from a working deployed source [JBOSS_HOME]/server/default/deploy/absences.ear 
to the newly generated project as deployed to jboss at [JBOSS_HOME]/server/default/deploy/seamTests-ear.ear

1.  Manually copy jboss-seam.jar from absences.ear to seamTests-ear.ear
2.  Manually copy the jars from within absences.ear/lib to seamTests-ear.ear (not within a lib sub-folder)
3.  Manually copy the images files from within absences.ear/absences.war/img to seamTests-ear.ear/seamTests.war/img (these files are either corrupted or not deployed at all)

There were also a few relative URL references that needed changing due to the rather different layout of the newly generated folders.  This affected my custom skin properties and references to graphics in the img folder.

The  seamTests application then works.  However, as soon as I make a change in eclipse or start the server from within eclipse, it undoes ALL of the above 3 steps as it re-dploys.

I don't know if any of this is helpful to those who are capable of working on the problem but here it is just in case.


I also tried generating a seamTests as a WAR rather than as an EAR.
The resulting application failed on an error while reading WEB-INF/components.xml:
Exception sending context initialized event to listener instance of class org.jboss.seam.servlet.SeamListener
That class is coorrectly defined as a listener in web.xml and all of the seam jars seem to be present in WEB-INF/lib

Another oddity:  The WEB-INF/classes folder contained a java source file Authenticator.java instead of Authenticator.class

Anyway, I guess I'll stick with SEAM-GEN for now until this is resolved.

Good luck to the hard workers who are trying to fix this !
(And thanks)

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4138199#4138199

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4138199

More information about the jboss-user mailing list