[jboss-user] [JBoss Tools (users)] - Re: JBoss Tools AS 1.0.0.GA update for JBoss 5 AS ?

dlmiles do-not-reply at jboss.com
Fri Mar 28 13:08:22 EDT 2008

"max.andersen at jboss.com" wrote : anonymous wrote : I agree with the issue on the other error being due to not using the rest of the nightly build, I did not download and take apart the nightly build to see why it did not gel.  Also why does Content Assist require access to IJBossRuntime (when I've not runtimes setup) and also why does Type Hierachy fail to work at all when IJBossRuntime class is apparently missing!  So what!
  |   | 
  | You need to explain that to me a bit better ;)
  | What kind of content assist is failing ?

All kinds, in all contexts I tried, on all artifacts I tried.  Simply unzip JBossTools-AS-*-nightly over your GA installation and bootup and try to do some Java work.

I really would not be so concerned about it, I'm pretty sure the issue is not with JBoss Tools but the way in which Eclipse hunts/looks/finds things.

anonymous wrote : anonymous wrote : < rant > Gee it would be really good when you booted eclipse and it detected a change in plugins if it diagnosed problems an tell you which things were new and which things have become disconnected/disabled < / rant >
  | start eclipse with -debug and you get the disconnected/disabled info in the Error Log view.

G-r-e-a-t   A-d-v-i-c-e   T-h-a-n-k   Y-o-u!

< sarcasm >Hey with that content assist problem (if you really wanna knock yourself out on that bug), try attaching GDB to the process and looking a look at the disassemble view.< /sarcasm >


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4139730#4139730

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4139730

More information about the jboss-user mailing list