[jboss-user] [EJB 3.0] - @Interceptors not working

tharter do-not-reply at jboss.com
Mon May 12 19:34:31 EDT 2008

I've just been beating this problem to death for about 3 days now. Maybe a year or so back I wrote some custom EJB3 interceptors. All was well. Now I find for no reason I can discern that they simply do not get invoked anymore.

Specifically there is nothing super complex going on. I have an interceptor class, annotated method @AroundInvoke and a bean method in my deployment unit marked with @Interceptors(MyInterceptor.class). This has worked for quite some time. Lately, due to some reliability problems, I switched from jrocket R26.4 to R27.4. It appears that JBoss still DEPLOYS the interceptors

2008-05-12 18:44:32,431 DEBUG [org.jboss.ejb3.EJBContainer] Method interceptors for  public com.tradedesksoftware.etsdata.users.group.Company com.tradedesksoftware.etsdata.DataManagerBean.getCompany(int): [InterceptorInfo{class=class com.tradedesksoftware.interceptors.AuthReturnInterceptor, aroundInvoke=Intercept}]

However when the business method is invoked, no interceptor. Same things seems to happen in unit tests using Embeddable EJB3, where the same interceptors also seemed to work fine previously. Even if I just add a 'do-nothing' interceptor that just spits out a log message, still not called.

Anyone have even a clue what I can do to try to figure this out? I'm at a loss here. Cannot go back to R26.4 of jrockit and can't live without the interceptors either :(

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4150212#4150212

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4150212

More information about the jboss-user mailing list