[jboss-user] [Installation, Configuration & DEPLOYMENT] - Re: Caused by: java.lang.NoClassDefFoundError: Ljavax/xml/na

Jessica134 do-not-reply at jboss.com
Thu May 22 07:44:47 EDT 2008

Thanks for you responce :)

Yes I'm sure, bc maven creates .jar. and I put these .jar on Jboss:

Firstrly, I put these generated .jar in folder 

C:\JBoss\jboss-4.0.5.GA\server\default\deploy\jbossws.sar\ of Jboss  but it doesn't work (same error: Caused by: java.lang.NoClassDefFoundError: Ljavax/xml/namespace/QName;)

Then, I try to put these .jar in 

C:\JBoss\jboss-4.0.5.GA\lib\endorsed\ but it doesn't work. (same error)

I've seen, that Jboss has .jar of Jaxb (jaxb-api.jar and jaxb-impl.jar) in bossws.sar. So, I moved it and put my .jar but it doesn't work. (same error)

I've seen that there are .jar of Jboss that contains the class javax/xml/namespace/QName, I've tried to move it and put my .jar, but again the same error.

I've seen also in  

C:\JBoss\jboss-4.0.5.GA\server\default\deploy\jbossws.sar\ there is wsdl4j.jar that contains the folders javax/xml/namespace/ but there isn't the Class Qname. So I tried to move it and put my .jars, but Jboss give me errors:

java.lang.NoClassDefFoundError: javax/jws/WebService

I tried to add the class Qname in the jar wsdl4j.jar, but again the error:

Caused by: java.lang.NoClassDefFoundError: Ljavax/xml/namespace/QName

I have no idea what I can do :(
I'm sure that the problem is on Jboss bc I haven't error in eclipse, but i don't know where is the problem

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4152640#4152640

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4152640

More information about the jboss-user mailing list