[jboss-user] [Persistence, JBoss/CMP, Hibernate, Database] - Re: Problems after upgrading to 4.2.2 with MySQL and BLOB

C-Box do-not-reply at jboss.com
Mon May 26 06:29:38 EDT 2008

Hi again

I can't say that the problem is really solved but we found a screw to turn that the error doesn't occur any longer...

within our application ear in the involved jar's --> meta-inf --> jboss-cmp-jdbc.xml we changed the read-ahead strategy from "on-find" to "on-load" and now it's working again.

Just came to it, while reading some comments in the jms config-file and JBoss-Wiki, that MySQL has some troubles reading more than one BLOB and therefore the "RecoverMessagesChunk" attribute can be set to 1.

So our jar's jboss-cmp-jdbc.xml is now starting with this defaults:

  |        <datasource>java:/AFPSDB</datasource>
  |        <create-table>false</create-table>
  |        <remove-table>false</remove-table>
  |        <row-locking>false</row-locking>
  |        <read-ahead>
  |           <strategy>on-load</strategy>
  |           <page-size>1000</page-size>
  |           <eager-load-group>*</eager-load-group>
  |        </read-ahead>
  |        <list-cache-max>1000</list-cache-max>
  |        <clean-read-ahead-on-load>false</clean-read-ahead-on-load>
  |        <entity-command name="no-select-before-insert"/>
  |     </defaults>

now it's working again.  But I guess it's not the real solution, so perhaps someone could clarify, if it's more a JBoss Bug (as it worked in 4.0.2 with "on-find") or a MySQL JDBC-Driver Problem (although direct SQL via JDBC is working fine). So I think JBoss 4.2.2 Problem!!?!?!

thanks (to anyone who at least thought that problem but had no idea )

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4153312#4153312

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4153312

More information about the jboss-user mailing list