[jboss-user] [JBossWS] - Re: Jboss 4.2.2 hangs when after deploying a WAR

tonioc do-not-reply at jboss.com
Thu Oct 30 16:59:15 EDT 2008

finally I obtained the log (which full filled my file-system)

It seems some recursive behavior is the cause of this

here is the log:

2008-10-30 18:01:08,213 INFO  [org.jboss.wsf.stack.jbws.WSDLFilePublisher] WSDL published to: file:/home/xtra/u/jdesa/mccg/jboss-4.2.2.GA/server/default/data/wsdl/wstest.war/EchoService23289.wsdl
  | 2008-10-30 18:01:08,394 DEBUG [org.jboss.wsf.framework.deployment.DeploymentAspectManagerImpl] EagerInitializeDeploymentAspect:Start
  | 2008-10-30 18:01:08,394 DEBUG [org.jboss.ws.metadata.umdm.UnifiedMetaData] Eagerly initialize the meta data model
  | 2008-10-30 18:01:08,397 DEBUG [org.jboss.ws.metadata.wsdl.xmlschema.JBossXSModel] Registered as anon type: {http://www.mccg.net/xsd/phoenix/base-types/claim.xsd:>claimInvolvedParty>listOfExtraAttr} -> Complex type name='http://www.mccg.net/xsd/phoenix/base-types/basic.xsd,#AnonType_listOfExtraAttribsObject',  base type name='anyType',  content type='ELEMENT',  isAbstract='false',  hasTypeId='false',  final='0',  block='0',  particle='("http://www.mccg.net/xsd/phoenix/base-types/basic.xsd":extraAttr{0-UNBOUNDED})',  derivedBy='RESTRICTION'.

There are 20Gb similar to the last line, I was not able to
find out a pattern that let me understand what is happening
it seems that the JBossXSModel (not sure what it is) is not capable of managing some kind of recursive references (?) inside an schema.

I tried a basic example Contact->ListOfAddress and Address->ListOfContact and it worked ok.

Continue investigating....
thanks to anybody who bothers reading my-emails

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4185824#4185824

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4185824

More information about the jboss-user mailing list