[jboss-user] [JBoss jBPM] - Re: Consuming webservice in jBPM JPDL (Eclipse)

chrlyck do-not-reply at jboss.com
Fri Sep 12 04:55:15 EDT 2008

Thanks again, i think we are getting somewhere... :)

OK, here goes. I have tried two methods. As mentioned i deploy using JPDL so i don't really know what my .par is named and what happens to it, but it shouldn't matter...

-clh.java (package)
-org.me.calculator (package)

I built a jax.war (zipped the mentioned files below and renamed to war). Then put it in the "jbpm-jpdl-3.2.3\deploy" dir.


This results in the err

anonymous wrote : Cannot load service endpoint interface: org.me.calculator.CalculatorWS

Right after "Debug:2". This is printed in the web-server but the webinterface returns

anonymous wrote : Information
  | Variables updated
  | Task completed

So i think this is close...

If i remove my .war file i get the exact same result so you must be right is a classloader issue...

Looking for the right solution since i don't know if i did my .war correctly i have tried putting all the JAR-files in the classpath (edited the run.bat so it imports them)

So my startup of the jboss server says:

anonymous wrote : ===============================================================================
  |   JBoss Bootstrap Environment
  |   JBOSS_HOME: C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server
  |   JAVA: C:\Program Files\Java\jdk1.5.0_16\bin\java
  |   JAVA_OPTS:  -Dprogram.name=run.bat -server -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.g
  | cInterval=3600000
  |   CLASSPATH: C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server\CP\activation.jar;C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server\CP\j
  | axb1-impl.jar;C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server\CP\jaxb-api.jar;C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server\CP\ja
  | xb-impl.jar;C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server\CP\jaxb-xjc.jar;C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server\CP\jbos
  | s-jaxws.jar;C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server\CP\jsr173_1.0_api.jar;C:\Program Files\Java\jdk1.5.0_16\lib\tools.ja
  | r;C:\Program Files\jBPM\jbpm-jpdl-3.2.3\server\bin\run.jar
  | ===============================================================================

This returns an error in the webinterface:

anonymous wrote : description The server encountered an internal error () that prevented it from fulfilling this request.
  | exception 
  | javax.servlet.ServletException: Servlet execution threw an exception
  | 	org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
  | root cause 
  | java.lang.NoClassDefFoundError: javax/xml/soap/FactoryLoader
  | 	javax.xml.ws.spi.Provider.provider(Provider.java:91)
  | 	javax.xml.ws.Service.(Service.java:83)
  | 	org.me.calculator.CalculatorWSService.(CalculatorWSService.java:47)
  | 	clh.java.calc.execute(calc.java:22)

So with the first example i get to line 24 of my code (Debug:2) in the 2nd i get to line 22 which is where i create the service... See below:

  | log.info("Debug:1");
  | CalculatorWSService service = new CalculatorWSService(); //line 22
  | log.info("Debug:2");
  | CalculatorWS port = service.getCalculatorWSPort(); //line 24
  | log.info("Debug:3");

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4176062#4176062

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4176062

More information about the jboss-user mailing list