[jboss-user] [JBoss Messaging] - JBoss MDB fails to consume from JBoss ESB queue

idaplan do-not-reply at jboss.com
Wed Sep 24 18:23:35 EDT 2008


we try to deploy a EJB3 MDB on a JBoss AS 4.2.2.GA which shall consume messages from a remote JBoss ESB 4.2.1.GA queue (both running under Linux).

As I have learned already, the JBoss ESB already uses JBoss Messaging while JBoss AS comes with JBoss MQ by default.

However, we tried to set up the RemoteJMSProvider as described in 

And we have put the jboss-messaging-client.jar into the JBoss AS's servers lib folder. 

The machine boots without errors but once some messages are available for consumption, we get the following error approx every 30 seconds:

05:32:42,366 WARN  [BisocketServerInvoker] org.jboss.remoting.transport.bisocket.BisocketServerInvoker$ControlMonitorTimerTask at 4672b784: detected failure on control connection Thread[control: Socket[addr=/172.xyz.xyz.xyz,port=3307,localport=42468],5,JBoss Pooled Threads] (4sj74h-ajpkoc-flih1kk3-1-flih2303-b: requesting new control connection

... and no messages are consumed by the MDB. 

Do we have to switch the JBoss AS from JBoss MQ completely to JBoss Messaging? 
We only want to deploy a simple MDB and we are not using any JMS from the JBoss AS at all!

By the way, we also tried to replace the orignal jboss-remoting.jar 2.2.2.SP1 of the JBoss AS with versions 2.5.0 and 2.2.2.GA.
But with the same result. 

Any suggestions?


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4178652#4178652

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4178652

More information about the jboss-user mailing list