[jboss-user] [Security & JAAS/JBoss] - Re: Problem turning on security manager with JBoss 4.0.4

osganian do-not-reply at jboss.com
Fri Sep 26 11:26:16 EDT 2008

The class org.jboss.security.SimplePrincipal exists in the following JARs under my jboss home:


Now, when I run only the server/default/lib/jbosssx.jar is being used.  I even renamed the client directory to clientzzz and when jboss starts up i can rename the directory, etc so I know those 2 jars shouldn't be in the game when JBoss is up and running.  But I still get a linkage error when I have:

  | grant principal org.jboss.security.SimplePrincipal "test" {
  |     permission javax.security.auth.AuthPermission "testPerm";
  | };

In my policy file.  Has anybody run across this?  Or know exactly how you are supposed to assign permissions to specific users/groups?

Thanks for any help

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4179102#4179102

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4179102

More information about the jboss-user mailing list