[jboss-user] [Installation, Configuration & DEPLOYMENT] - com.sun.tools.javac.Main is not on the classpath

anupjani do-not-reply at jboss.com
Sat Apr 4 20:37:04 EDT 2009

I was getting following error when tried running a JSP in a simple JSP + Servlet based application on JBoss4.0

03:09:08,236 ERROR [Engine] StandardWrapperValve[jsp]: Servlet.service() for servlet jsp threw exception
Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK
	at org.apache.tools.ant.taskdefs.compilers.CompilerAdapterFactory.getCompiler(CompilerAdapterFactory.java:105)

I ensured tools.jar was present in:
1. project library
2. %JAVA_HOME%\lib
3. C:\JBoss4\server\default\lib

I also ensured that JAVA_HOME was my JDK root folder.
i.e. set JAVA_HOME=C:\Program Files\Java\jre1.6.0_04

But the problem got solved ONLY after placing "tools.jar" inside the "ext" folder like this
C:\Program Files\Java\jre1.6.0_04\lib\ext\tools.jar

I think there is class loader's problem in JBoss4.

Kindly give some helpful comments.
Anup Jani

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4223481#4223481

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4223481

More information about the jboss-user mailing list