[jboss-user] [Installation, Configuration & DEPLOYMENT] - NoSuchMethodError when accessing library class.

leomrlima do-not-reply at jboss.com
Fri Apr 24 07:35:01 EDT 2009

My JBoss Version is 4.2.3, and I'm using Sun's JDK 1.6.0_11 in a RHEL 2.6.9-55.ELsmp. I'm also using current Apache POI 3.5-beta5 (poi-3.5-beta5.jar). 

When my application tries to access a method (that compiles OK in Eclipse using the same .jar file), it throws a:

java.lang.NoSuchMethodError: org.apache.poi.hssf.usermodel.HSSFCell.setCellValue(Lorg/apache/poi/hssf/usermodel/HSSFRichTextString;)V

Which I find strange, as the only library containing POI files is the correct one. I tried to validate the .jar file used accessing "name=Default,service=LoaderRepository" from the JMX Console. The method displayClassInfo() gets me the same UnifiedClassLoader3 object hash and the correct code source (++++CodeSource: (file:/data/jboss/server/default/lib/poi-3.5-beta5.jar )). 

I tried to 'google' around but I found only references about multiple .jar files, which I don't know is the problem here, because I get the correct .jar when I display the class info.

What can I do to resolve this? Is there a way to invoce "displayClassInfo()" from inside the App context?


View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4226606#4226606

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4226606

More information about the jboss-user mailing list