[jboss-user] [JBossWS] - Problem deploy WS (ClassFormatError)

konstt2000 do-not-reply at jboss.com
Wed Aug 12 08:48:40 EDT 2009


Hi, 

I have a project java and compile it with ANT. When deploy the war (with his web.xml, etc) gives me a error.


  | 14:23:19,852 ERROR [MainDeployer] Could not create deployment: file:/D:/jboss-soa-p.4.3.0/jboss-as_SOA/server/default/deploy/WebServiceGde.war
  | java.lang.ClassFormatError: Method "getDescripcion" in class es/ree/gde/webservice/logica/WebServiceGde has illegal signature "ourceFile"
  | 	at java.lang.ClassLoader.defineClass1(Native Method)
  | 	at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
  | 	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
  | 	at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
  | 	at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
  | 	at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
  | 	at java.security.AccessController.doPrivileged(Native Method)
  | 	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
  | 	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
  | 	at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
  | 	at org.jboss.wsf.container.jboss42.JAXWSDeployerHookPreJSE.getEndpointBeans(JAXWSDeployerHookPreJSE.java:145)
  | 	at org.jboss.wsf.container.jboss42.JAXWSDeployerHookPreJSE.isWebServiceDeployment(JAXWSDeployerHookPreJSE.java:104)
  | 	at org.jboss.wsf.container.jboss42.ArchiveDeployerHook.deploy(ArchiveDeployerHook.java:87)
  | 	at org.jboss.wsf.container.jboss42.DeployerInterceptor.create(DeployerInterceptor.java:79)
  | 	at org.jboss.deployment.SubDeployerInterceptorSupport$XMBeanInterceptor.create(SubDeployerInterceptorSupport.java:180)
  | 	at org.jboss.deployment.SubDeployerInterceptor.invoke(SubDeployerInterceptor.java:91)
  | 	at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
  | 	at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
  | 	at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
  | 	at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
  | 	at $Proxy46.create(Unknown Source)
  | 	at org.jboss.deployment.MainDeployer.create(MainDeployer.java:969)
  | 	at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:818)
  | 	at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:782)
  | 	at sun.reflect.GeneratedMethodAccessor24.invoke(Unknown Source)
  | 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  | 	at java.lang.reflect.Method.invoke(Method.java:585)
  | 	at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
  | 	at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
  | 	at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
  | 	at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
  | 	at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
  | 	at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
  | 	at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
  | 	at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
  | 	at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
  | 	at $Proxy9.deploy(Unknown Source)
  | 

If I believe a project web in eclipse and deploy the webservice works fine.
I believe 
I believe that the classes are not compiled well. In addition they occupy differently the .class that I compile that those that eclipse generates. ¿?¿?¿??

I work with JDK1.5 and JBOSS.4.3

Thanks.

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4249211#4249211

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4249211




More information about the jboss-user mailing list