[jboss-user] [Clustering] - HA Singleton service lookup in cluster

mayankmit2002 do-not-reply at jboss.com
Mon Aug 24 05:34:20 EDT 2009


Setup
  2 instances of Jboss AS 4.2.3GA running on different machines
  One HA-Singleton (type Barrier) service is deployed on both nodes, and is responsible to perform some operation.
  One SLSB using our service to perform some operation and is clustered.
  One application, that calls the method of session bean.

Scenario
  My client is calling the session bean to fire an event and to perform some operations of my HA singleton service.

Problem
  Now my problem is that, when i tried to call the session beans method, on one of the node it says my HA service is not bound while on other it performs the operation.
  I even tried to look-up the HA service using RMIAdaper in my session bean but still it says service not bound.



  

  

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4251126#4251126

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4251126



More information about the jboss-user mailing list