[jboss-user] [JBoss Cache: Core Edition] - Re: Problems with Transaction Manager

fatboysuns do-not-reply at jboss.com
Wed Feb 4 08:51:47 EST 2009

Yes I have, When I try JbossTransactionManagerLookup, I get a classcast exception. I did try the JbossstandaloneJTAlookup too with no luck.

I have tried to even upgrade my jboss from 4.05 to 4.23 with no luck. The surprising thing there was, When I ran a test to basically typecast arjuna.ats.JbossATX.transactionManager, which was the transactionManager that was getting returned in 4.23, to javax.transaction.TransactionManager, It ran fine. I did see that it had a parent class which implements TransactionManager. But When I ran I via the app, I got a classcast Exception again. I am not sure what I should do.

This was just a test as I dont think I can upgrade Jboss in production anytime soon too. Do you think I should use jboss-cache 2.x version instead of the 3.x version? If so which version does support jboss searchable?

Any help would be great.

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4206970#4206970

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4206970

More information about the jboss-user mailing list