[jboss-user] [Beginners Corner] - Re: JBoss 5.0.0.GA and RedHat compatibility

ramboid do-not-reply at jboss.com
Mon Feb 16 07:20:03 EST 2009

Thank you for your reply.  I reviewed the link in your email and it looks like my server is configured with the proper entries in the hosts file and is using the correct ip protocol.  I think that something is precluding JBoss from binding to the 8080 and other ports.  Moreover, when I run JBoss4.2.3 instead of JBoss 5.0.0.GA, the server binds properly to the 8080 and 8443 ports but the shutdown scrit (shutdown.sh) freezes and I must kill the process to stop JBoss.

I am getting the following warning and errors in the server.log file when I run JBoss5.0.0.GA with the script run.sh -b
[root at pbsiemr log]# cat server.log|grep WARN
2009-02-14 13:49:32,755 WARN  [org.jboss.annotation.factory.AnnotationCreator] (main) No ClassLoader provided, using TCCL: org.jboss.managed.api.annotation.ManagementComponent
[root at pbsiemr log]# cat server.log|grep ERROR
2009-02-14 13:49:33,412 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] (main) Error installing to Create: name=TransactionManager state=Configured
2009-02-14 13:49:34,747 ERROR [org.jboss.system.server.profileservice.ProfileServiceBootstrap] (main) Failed to load profile: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):
 -> TransactionManager{Configured:**ERROR**}
 -> TransactionManager{Instantiated:**ERROR**}
 -> TransactionManager{Create:**ERROR**}
 -> TransactionManager{Configured:**ERROR**}
*** CONTEXTS IN ERROR: Name -> Error
TransactionManager -> **ERROR** | com.arjuna.ats.arjuna.exceptions.FatalError: [com.arjuna.ats.internal.arjuna.utils.SocketProcessId_2] - SocketProcessId.getpid could not get unique port.

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4210315#4210315

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4210315

More information about the jboss-user mailing list