[jboss-user] [JBossWS] - Re: resource injection in WS handler not working in jboss JA

gang.yang do-not-reply at jboss.com
Wed Feb 25 17:38:56 EST 2009


I also hit this problem now, which is a blocking one since I can not pass in any info to the handler w/o this capability.

According the JAX-WS spec, you should also be able to lookup up the  names defined by the associated Java EE component using JNDI from the handler. I tried that. It worked for handlers that is configure for the Web container. But it did not work for handlers that is configure for the EJB3 container. So I'm really dead in the water since we use EJB3 annotated WS endpoint.

I understand that the fix for the resource injection is targeted for JBossWS 3.1.1. But could there be a fix for the JNDI lookup not working earlier? Or should I create a trouble report for the JNDI?


View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4213196#4213196

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4213196

More information about the jboss-user mailing list