[jboss-user] [JBoss jBPM] - Re: Trying to persist process instances - need some help

terigox do-not-reply at jboss.com
Mon Jan 5 12:57:01 EST 2009

Thanks again for the help kukeltje,

If I remove the jbpm.cfg.xml I'm not exactly sure how to get a hold of my jbpmContext, I tried:

  | 		JbpmConfiguration jbpmConfiguration = JbpmConfiguration.getInstance();
  | 		JbpmContext jbpmContext = jbpmConfiguration.createJbpmContext();

But that leaves me with this exception

  | java.lang.ClassCastException: org.jbpm.persistence.jta.JtaDbPersistenceServiceFactory cannot be cast to org.jbpm.svc.ServiceFactory
  | 	org.jbpm.svc.Services.getServiceFactory(Services.java:117)
  | 	org.jbpm.svc.Services.getService(Services.java:134)

I tried putting my jbpm.cfg.xml back and added a bit more content, following the included guide for jBPM and made my jbpm.cfg.xml look as follows:

  | <jbpm-configuration>
  | 	<jbpm-context>
  | 		<service name='persistence' factory='org.jbpm.persistence.db.DbPersistenceServiceFactory' />
  | 	</jbpm-context>
  | 	<string name='resource.hibernate.cfg.xml' value='hibernate.cfg.xml' />
  | 	<string name='resource.business.calendar' value='org/jbpm/calendar/jbpm.business.calendar.properties' />
  | 	<string name='resource.default.modules' value='org/jbpm/graph/def/jbpm.default.modules.properties' />
  | 	<string name='resource.converter' value='org/jbpm/db/hibernate/jbpm.converter.properties' />
  | 	<string name='resource.action.types' value='org/jbpm/graph/action/action.types.xml' />
  | 	<string name='resource.node.types' value='org/jbpm/graph/node/node.types.xml' />
  | 	<string name='resource.varmapping' value='org/jbpm/context/exe/jbpm.varmapping.xml' />
  | </jbpm-configuration>

I get the same error:

  | java.lang.IllegalArgumentException: Can not set long field org.jbpm.graph.def.GraphElement.id to org.jbpm.graph.node.MailNode
  | 	sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException(UnsafeFieldAccessorImpl.java:146)
  | 	sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException(UnsafeFieldAccessorImpl.jav

I'm confused as to why it's trying to create a "MailNode" anyway. None of my nodes in my process definition are MailNodes. Does having a task-node force it to also create a MailNode? I could try an even simpler example with only a single StateNode to see if it works at all with explicitly saving.

Any thoughts? I really appreciate the help!

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4199600#4199600

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4199600

More information about the jboss-user mailing list