[jboss-user] [JBoss Cache: Core Edition] - Transaction manager file not found (Repost)

fatboysuns do-not-reply at jboss.com
Thu Jan 29 06:40:42 EST 2009


Hi,
   I am using Jboss cache searchable in my application. I have a method which I use to cache all that I need. I have exposed this from the JMX-console. The method, creates a singleton "Cache" and "SearchableCache" object and uses this to perform the caching. The method works fine if I have no "Configuration" element attached to it, but when I try to use a Configuration for my cache, I am getting a
java.lang.ClassNotFoundException: org.jboss.cache.transaction.GenericTransactionManagerLookup

I have tried to create configurations via both Java and xml variants. The interesting part to the whole thing is, I get this exception only when accessing the method from JMX. If I access from the app, it seems to work absolutely fine.

I have tried using , the 3 transaction managers provided by jboss cache and also JTA.

My app runs on jboss 4.05 and uses Spring for service, transaction and configuring JMX. 

Any help is appreciated.

Regards
Sundar S

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4205374#4205374

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4205374



More information about the jboss-user mailing list