[jboss-user] [JNDI/Naming/Network] - JBoss / Eclipse RCP: Could not dereference object

RobertWilson do-not-reply at jboss.com
Mon Jul 20 09:07:50 EDT 2009

I have a problem instantiating my remote session bean from my Eclipse RCP client. I get a nest of 3 exceptions:

javax.naming.NamingException: Could not dereference object
Caused by: java.lang.reflect.UndeclaredThrowableException
Caused by: java.land.ClassNotFound: company.service.SessionRemote

Interestingly, this final exception is thrown from the JBoss ClassLoaderUtility. It appears to me that JBoss is overriding Eclipse's ClassLoader, and can't find the relevant class.

This is definetely an Eclipse/JBoss issue - when I run a standalone JUnit test, all the tests pass. When I run it from an Eclipse plug-in test, it fails.

Is this normal behvavious? Can I influence the JBoss classloader at all?

Other key points:

* There is no output on the server (i.e. client-side issue)
* Currently both the client and the JBoss server are running from the same JDK

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4244641#4244641

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4244641

More information about the jboss-user mailing list