[jboss-user] [JBoss jBPM] - Re: Concurrency Problem

wjn811 do-not-reply at jboss.com
Fri Jun 19 02:16:48 EDT 2009

hi kukeltje, 

very appreciate your replies!

I'm a new one here. And I even don't know JIRA... What a pity!

I go through the topic you have metioned


If I don't misunderstand that post, changing org.hibernate.dialect can get my problem solved? 

However, my org.hibernate.dialect is configured as org.hibernate.dialect.MySQLInnoDBDialect...

<property name="hibernate.dialect">org.hibernate.dialect.MySQLInnoDBDialect</property>
  | <property name="hibernate.connection.driver_class">com.mysql.jdbc.Driver</property>
  | <property name="hibernate.connection.url">jdbc:mysql://localhost:3306/jbpm4db</property>
  | <property name="hibernate.connection.username">root</property>
  | <property name="hibernate.connection.password">123456</property>
  | <property name="hibernate.hbm2ddl.auto">update</property>
  | <property name="hibernate.show.sql">true</property>
  | <mapping resource="jbpm.repository.hbm.xml" />
  | <mapping resource="jbpm.execution.hbm.xml" />
  | <mapping resource="jbpm.history.hbm.xml" />
  | <mapping resource="jbpm.task.hbm.xml" />
  | <mapping resource="jbpm.jpdl.hbm.xml" />
  | <mapping resource="jbpm.identity.hbm.xml" />

So I think my problem is different from that. ?

And the ConstraintViolationException
 here is because `FK_EXEC_SUPEREXEC` but not `FK_EXEC_INSTANCE` (Yes, it's due to that I use sub-process. Because if I put these 2 fork flows into One process, one embedded into another, tasks in Inner-Fork-Flow will be created twice)

This time I try to be clever to  USE SOME KIND OF SEARCH FUNCTIONALITY (I was stupid enough yesterday~~). I learn Google! hahaha

Fortunately, I find this issue list

https://jira.jboss.org/jira/secure/BrowseVersion.jspa?id=10052&versionId=12313199&showOpenIssuesOnly=true (And I know JIRA! Fortunately again)

And I find this issue JBPM-2303 UNRESOLVED   Exception with a process containing a fork/join  

You can touch it:https://jira.jboss.org/jira/browse/JBPM-2303

I ran that tests and got exceptions. I think join/fork flow has its own bugs.

I should go to see what happens in jBPM4. I should have enough time to do that.  It's my fault.

I really want to know what's wrong with my code, What is the actual reason caused that exception happens. If it is proved to be a bug, I can sleep well tonight~~ hahaha

Please help me again. Thx!

Or I have to wait for jBPM4 released? hahahaha

My e-mail: crazydog.eric at gmail.com

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4238661#4238661

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4238661

More information about the jboss-user mailing list