[jboss-user] [EJB 3.0 Users] - Re: NamedQuery problem: TABLE is not mapped

pi4630 do-not-reply at jboss.com
Tue Nov 24 07:49:47 EST 2009

Wolfgang, thanks for caring, thumbs up! The book I'm studying does not mention case sensitivity, and I thought the statement would be table related, not class related.

So thank you very much, because after changing the case, it worked.

There's one thing: I have indeed a artnr field and public getters and settes which render it Artnr (getArtnr and setArtnr). I tried your hint first, i.e. 
  | SELECT a FROM Artikel a ORDER BY a.Artnr but this yields an exception when deploying: ERROR [SessionFactoryImpl] Error in named query: findAllArtikel
  | org.hibernate.QueryException: could not resolve property: Artnr of: ser.kap08.Artikel [SELECT a FROM ser.kap08.Artikel a ORDER BY a.Artnr]
If I try with the field case instead, i.e.   SELECT a FROM ser.kap08.Artikel a ORDER BY a.artnr
it's fine.

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4267287#4267287

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4267287

More information about the jboss-user mailing list