[jboss-user] [Persistence] - AS 5.1 - ResultSet closed, worked fine in 4.0.5

lpmon do-not-reply at jboss.com
Fri Oct 9 12:09:31 EDT 2009

I have a session been that takes an SQL select query string (not EJBQL), runs the query and returns the resultset.   This worked fine in 4.0.5.  In 5.1.0 the resultset is open inside the session bean method but when trying to access the result set  (rs.next()) in the method that called the session bean an exception is thrown saying the result set is closed.  Something in either the AS or Hibernate must have changed for 5.x . ??????

More info:  The session bean looks up a non-transactional JDBC datasource (regular pooled connection), creates a connection, creates a statement and executes that statement.  

Again, exact same code works just fine in 4.0.5.  There is no problem accessing the resultset inside the session bean it is only when you return the resultset and try to access it in the caller of the session bean that the problem occurs.

Is this a bug or have the rules changed?

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4259672#4259672

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4259672

More information about the jboss-user mailing list