[jboss-user] [JBoss Remoting Users] - Re: Messaging blocked by long time-out

radimchatkalahari do-not-reply at jboss.com
Mon Oct 19 00:57:48 EDT 2009

I was facing the same problem for a long time using
jboss-messaging 1.4.2GA-SP1  & jboss-remoting 2.2.2SP11

Yesterday I tried jboss-messaging 1.4.5GA together with
jboss-remoting 2.2.3SP1
but behavior was the same:

  | 2009-10-19 03:27:53,687 ERROR [org.jboss.remoting.transport.socket.SocketClientInvoker] Got marshalling exception, exiting
  | java.io.IOException: Connection reset by peer: socket write error
  | ...and after 2 seconds
  | 2009-10-19 03:27:55,687 WARN [org.jboss.messaging.core.impl.ChannelSupport] Queue[8724664/231/188656-y68h-xkppjy0g-1-655exx0g-xocyvy-2c3gs4] has reached maximum size, Reference[4166470286297938638]:NON-RELIABLE will be dropped
and after that communication works for a couple of seconds and then 
ALL communication with ALL clients to/from jboss STOPPED
jboss log (with debug level) is after that time empty.
and thing gone even worst, because, when this occurred @ jbrem 2.2.2SP11
I just restarted jboss and all the clients reconnects correctly.
Using 2.2.3SP1 I had to restart ALL clients together with Jboss
(I tried left 2 clients with jbrem2.2.2SP11 and those ones reconnected automatically!)

my remoting-bisocket-service.xml @ jboss side looks like this

  | ...
  |             <invoker transport="bisocket">
  |                <attribute name="stopLeaseOnFailure" isParam="true">true</attribute>
  |                <attribute name="clientLeasePeriod" isParam="true">10000</attribute>
  |                <attribute name="validatorPingPeriod" isParam="true">10000</attribute>
  |                <attribute name="validatorPingTimeout" isParam="true">5000</attribute>
  |                <attribute name="registerCallbackListener">false</attribute>
  | 	           <attribute name="timeout" isParam="true">0</attribute>
  |                <attribute name="numberOfRetries" isParam="true">10</attribute>
  |                <attribute name="JBM_clientMaxPoolSize" isParam="true">200</attribute>
  |                <attribute name="callbackTimeout">10000</attribute>        
  |             </invoker>
  | ...
do you have any suggestions how to solve this problem?

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4260975#4260975

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4260975

More information about the jboss-user mailing list