[jboss-user] [JBoss Tools Users] - Re: Web App Libraries not published?

deanhiller do-not-reply at jboss.com
Tue Sep 15 10:39:42 EDT 2009

well, I finally got it to work in jboss tools kind of, but I sure could not mount my project from jboss tools.  Here is the exact play by play

First, my dir structure
------libexclude - jars not to be put in WEB-INF/lib
------libinclude -- jars to be put in WEB-INF/lib
------webroot - xhtml files and jpgs, etc
---------WEB-INF - descriptors (NO jars, no class files)

In WTP, I finally managed to mount this project doing the following
1. checkout project from CVS (then find out there is no way to convert to JSF like JBoss has, but alas, I tried that way in JBoss and it didn't work)
2. then delete project but leave on filesystem
3. delete .project and .classpath files to make sure it is a clean java project with no eclipse relationship

NOW, I figure I can mount using dynamic web project so I do that
4. choose new->dynamic web project
5. Use default must stay checked and you HAVE to make sure the path maps to where your project is.  If you uncheck it and pick your project, it gives you a weird error saying project already exists but if you leave it checked, it is fine with your project being there which is odd.
(I tried these same exact steps with jboss as well by the way)
6. Next step was then to choose the properties->J2EE Module Dependencies and add all the jars there
7. NExt add a tomcat runtime to the servers tab and deploy
deploying worked great in WTP.  Following all these same steps in JBoss, deployment failed with ClassNotFoundExceptions like Web App Libraries were not being deployed or something

Workaround....to work around this, you HAVE to mount the java project while eclipse is WTP and then install JBoss tools AFTER you have mounted the project and deployment to tomcat works.  then, for some reason, JBoss tools is ok.

Another really really annoying thing is when I add the seam facet, it adds jars to input/webroot/WEB-INF/lib folder which is very annoying..our jars are in libinclude and all generated content we put in output folder so just deleting the output folder is enough to clean a project.  At some point, jboss tools had put classes in input/webroot/WEB-INF/classes as well even though our output folder is eclipsegen folder.

I hope this helps.  I spent 3 days on this.

Oh, and my personal opinion is that the wizards should really really ask for 4 or 5 things
1. javasrc
2. where jars are for WEB-INF/lib
3. where jars are for libexclude(and this is where runtime jars should be put so project can build without external dependencies if user wants)
4. where root of web files are
5. maybe an output folder if jboss tools really needs to write out classes, jars into WEB-INF(and then just copy over webroot) sort of like the eclipse output folder for classes......it is configurable.

Lastly, in JSF WTP, you can choose self manage jars(this is a GREAT feature allowing lots of flexibility)...when adding Seam, it does not let you do that, there is no option.  

I hope this helps some, thanks for the work!!!


View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4255318#4255318

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4255318

More information about the jboss-user mailing list