[jboss-user] [jBPM] - Process Variable cannot be casted and accessed

Gerardo Navarro Suarez do-not-reply at jboss.com
Wed Apr 28 15:49:53 EDT 2010


Gerardo Navarro Suarez [http://community.jboss.org/people/GerardoNS] replied to the discussion

"Process Variable cannot be casted and accessed"

To view the discussion, visit: http://community.jboss.org/message/540095#540095

--------------------------------------------------------------
Hallo Bernd,

thank you very much for this hint. But nevertheless I couldn't figure out why I get this error or why the classes are deployed twice.

Like I said before I use the GPD plugin to develop and also deploy the processes. When I press the "Deploy Process Archive ..." Button eclipse says that the deployment succeeded. So I trust eclipse and it's GPD plugin, but obviously there appears to happen something wrong.

My question is now:

1) You said: "So a good start would be to look how the class is packaged". Well, the class is in the package "de.hpi.pois.klassen" and the action are in the package "de.hpi.pois.action". But I think that this is not what you mean by that phrase. I've tried to find the archive that is created by the GPD and to look how the classes are packaged there, but I couldn't find the archive. Do you know where the archives could be?

2) Where I can find the deployment artifacts? (google doesn't give me a good answer)

3) You said that you have to take a closer look to my source. So, do you think that the problem lies in the code?

An alternative could deploy it with an ant target. Meanwhile, I tried this alternative but up to this point without any success.

Thanks again for your help.

Greetings,

Gerardo


--------------------------------------------------------------

Reply to this message by going to Community
[http://community.jboss.org/message/540095#540095]

Start a new discussion in jBPM at Community
[http://community.jboss.org/choose-container!input.jspa?contentType=1&containerType=14&container=2034]

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20100428/deeddf48/attachment.html 


More information about the jboss-user mailing list