[jboss-user] [JBoss Web Services] - Generated WSDL looses xsd references

Peter Cebokli do-not-reply at jboss.com
Sun Dec 19 10:58:28 EST 2010

Peter Cebokli [http://community.jboss.org/people/peterce] created the discussion

"Generated WSDL looses xsd references"

To view the discussion, visit: http://community.jboss.org/message/576738#576738

We have to build services based on WSDLs specified by third party. This WSDL files are referencing some xsd schemas. Our problem is when we generate stubs with JbossWS command tool or via Eclipse wizard, the classes are generated, but the WSDL file which is exposed in Jboss WS console has all types inlined, also restrictions from originating schema are lost. We are using Jboss 5.1 and Eclipse with latest Jboss tools. We tried to upgrade to latest Jbossws-native (3.4 version) but still got the same result. What is the cause that the WSDL references aren't kept?

Reply to this message by going to Community

Start a new discussion in JBoss Web Services at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20101219/2cce9b3f/attachment.html 

More information about the jboss-user mailing list