[jboss-user] [Beginner's Corner] New message: "Re: Port already in use: 1098 - URGENT"

damon weinstein do-not-reply at jboss.com
Fri Feb 26 23:21:11 EST 2010

User development,

A new message was posted in the thread "Port already in use: 1098 - URGENT":


Author  : damon weinstein
Profile : http://community.jboss.org/people/damonweinstein

Hi Sashi,
I ran into a similar problem:  The port which was supposed to have been in use never showed up in netstat -a -o and if I changed the port to another port - the new port would show up as already in use.
My problem turned out to be: the wrong value to -b of the startup script.
I was using my external IP address instead of my internal (to the lan) IP address so for example:
run.bat -b     <--- the ip address of my router from the outside
run.bat -b  -b       <--- the ip address of the machine running jboss within the lan
I can't explain why this problem manifested the way that it did - but using the internal ip address fixed it.


To reply to this message visit the message page: http://community.jboss.org/message/528954#528954

More information about the jboss-user mailing list