[jboss-user] [JBoss Microcontainer Development] New message: "MutableAttachments.addAttachment is counter-intuitive"

Carlo de Wolf do-not-reply at jboss.com
Tue Jan 12 09:21:08 EST 2010

User development,

A new message was posted in the thread "MutableAttachments.addAttachment is counter-intuitive":


Author  : Carlo de Wolf
Profile : http://community.jboss.org/people/wolfc

The MutableAttachments API defines a lot of addAttachment functions, which should actually be named setAttachment.
Because I'm not adding (another) attachment named <name>, but overriding any previous attachment named <name> with a new one. Alternatively it could be called putAttachment (in line with the Map API).


To reply to this message visit the message page: http://community.jboss.org/message/519537#519537

More information about the jboss-user mailing list