[jboss-user] [jBPM] - New version of process with modification in java class : the change is not taken into account

Maciej Swiderski do-not-reply at jboss.com
Tue Mar 23 14:02:17 EDT 2010

Maciej Swiderski [http://community.jboss.org/people/swiderski.maciej] replied to the discussion

"New version of process with modification in java class : the change is not taken into account"

To view the discussion, visit: http://community.jboss.org/message/533543#533543

>  What do you mean exactly by : I do deploy directly to data base without container
I mean that I deploy my resources directly to data base using ant task, pretty the same as test cases do. So application server is not involved at all. I suspect that this is the case for you. That either classes or class loaders are cached somehow...
> What are the java classes used by jbpm? the classes in the database lobs or the classes contained in the jar copied to userlibs?
I would say that these that are stored in data base but as your case illustrates it is not always true. Since either way class loaders are involved it is probably issue with them. If classes are not available for application server (not placed in userlibs) then the only one is to load them from LOB.

Have you tried to stop the server, copy jar to user libs and start server again? Perhaps that would make a difference.

Attached eclipse project with your test case that I tried yesterday.



Reply to this message by going to Community

Start a new discussion in jBPM at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20100323/e5569734/attachment.html 

More information about the jboss-user mailing list