[jboss-user] [EJB 3.0] - how to debug deployment issues

Jason Novotny do-not-reply at jboss.com
Mon Nov 1 17:07:09 EDT 2010

jnovotny [http://community.jboss.org/people/jnovotny] created the discussion

"how to debug deployment issues"

To view the discussion, visit: http://community.jboss.org/message/569188#569188


After migrating from Jboss 4.2.3GA to JBoss 5.1.0GA I get these errors:

   Deployment "persistence.unit:unitName=persistence.xml#emCore" is in  error due to the following reason(s):  java.lang.IllegalArgumentException: Null file
   Deployment  "jboss.j2ee:jar=mach_EJB.jar,name=TariffCheckReminderJob,service=EJB3"  is in error due to the following reason(s):  org.jboss.deployers.spi.DeploymentException: MessagingType  'org.quartz.Job' not found in resource deployment  jboss.jca:service=RARDeployment,name='jms-ra.rar'

I can't for the life of me figure out how to debug the  problem. I've even tried to import JBoss source code into my IDE but  then there are third party JBoss source jar files that I dive into and  the errors are very unfriendly. What file is null? Why is MessagingType  not found in resource deployment? I specified

@MessageDriven(activationConfig = {
    @ActivationConfigProperty(propertyName = "cronTrigger", propertyValue =  "0 0 10 ? * FRI")
public class TariffCheckReminderJob implements Job {

which worked fine under 4.2.3...

Also, I set all Threshold entries to TRACE in server/default/conf/log4j.xml but still not seeing any debug entries... is there something else I must do?

Thanks a lot, Jason

Reply to this message by going to Community

Start a new discussion in EJB 3.0 at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20101101/ed465079/attachment-0001.html 

More information about the jboss-user mailing list