[jboss-user] [Javassist] - Javassist in Android : get in ClassPool not working ?

Julian J. do-not-reply at jboss.com
Tue Nov 2 18:20:39 EDT 2010

julian_j [http://community.jboss.org/people/julian_j] created the discussion

"Javassist in Android : get in ClassPool not working ?"

To view the discussion, visit: http://community.jboss.org/message/569401#569401


I'm new with Javassist. I try to integrate it in Android (2.2) for my master thesis.

The problem is that the find() and the get() methods from the ClassPool always return either null (for find) or throw a NotFoundException (for get) when I try to get some user class. I inspected the source code of both methods, but everything seems good (but the classloading mechanisms are still complex for me ...)

I also tried to play with the importPackage(), appendClassPath() and appendSystemPath() methods of the ClassPool, but the problem is still the same: Javassist is not able to find the classes of my application.

I wonder if the source comes from the Dalvik, and if I can do something to overcome it.

Any Idea ?


Reply to this message by going to Community

Start a new discussion in Javassist at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20101102/b74a523d/attachment.html 

More information about the jboss-user mailing list